Home Page Forums Troubleshooting/Help OSX Installation

This topic contains 3 replies, has 2 voices, and was last updated by  david_ko 8 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #4462


    I’m getting this error when I try to install the Python package on OSX.

    $ pip3 install pylinkbot
    Collecting pylinkbot
    Could not find a version that satisfies the requirement pylinkbot (from versions: 2.3.0.linux-i686)
    No matching distribution found for pylinkbot



    Hi raystuckey,

    What version of OSX and Python are you running? You can find your python version with the following command:

    python3 –version

    Our Linkbot module expects to find Python 3.4 on Mac systems.


    – David



    My python version 3.5.1.



    Ah hah, that explains it.

    We have a few options:

    1. Wait for me to compile and release it for Python 3.5 (I can try to find some time to do this today, but I can’t guarantee anything at this point 🙁 )
    2. Install Python 3.4 and use that for Linkbot Labs.
    3. Compile PyLinkbot yourself from https://github.com/BaroboRobotics/PyLinkbot (This is not exactly an easy task)

    Option 2 might be the easiest/fastest route, and there are several accepted methods of having multiple Python environments on a single computer, particularly using “virtualenv” https://www.dabapps.com/blog/introduction-to-pip-and-virtualenv-python/ .

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.